Installing Elgg

Asked by:
maryclove / 20 Points
Time:
2011-08-17 8:18 pm EST
Category:
How To
Hits:
3,461
I have been trying to install Elgg software on my server and not succeeding.
www.elgg.org

I'm following the directions, I think, but the help on elgg site seems to written at a higher level than I can understand.

I have successfully installed WordPress and my website, but this one seems trickier.

Thanks!

To ask this user for more information, please first login.

To submit an answer, please login.

Best answer chosen by Web Hosting Hub staff

0

KevinW
591 Points
2011-08-18 8:20 am EST
Hello,

I finally found what was causing the issue and was able to get Elgg installed. First, I followed all the steps from their <a href='http://docs.elgg.org/wiki/Installation' target='_blank'>official documentation</a>. Once I created my database and the data folder as specified, I uploaded all the files to a directory I called elgg. When I went to install the software however, I got a blank page.

I set the .htaccess to show me the error causing the blank page, and it was a memory_limit error. I finally found out what was causing it. In the files you upload from elgg into your elgg directory, they have included a .htaccess file. This is great since it has most of the settings, but there was one setting incorrect in the file. <a href='http://www.webhostinghub.com/help/learn/website/how-to/how-to-edit-your-htaccess-file' target='_blank'>Open the .htaccess file</a> in your Elgg directory and look for this code (lines 28 and 29):

<code_block># limit the maximum memory consumed by the php script to 64M
php_value memory_limit 64M</code_block>

What is happening is the .htaccess is setting the memory at 64M, when the Web Hosting Hub servers default at 512M. 64M isn't enough to run the software, so what we will do is "comment out" the line. This will mean the software will read the memory limit from our servers and not the .htaccess file. To do this, just add a # next to the line:

<code_block># limit the maximum memory consumed by the php script to 64M
# php_value memory_limit 64M</code_block>

Save it, and visit the directory in your browser to try to install the software again. If you are having problems in any of the other steps, just let me know, now that I have it installed on my test domain I should be able to answer any questions you have!

- Kevin

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.