Iphone cannot connect with correct mail settings ios7

Asked by:
HubFans / n/a Points
Time:
2014-06-03 6:29 pm EST
Category:
Iphone
Hits:
137
Mail on iPhone authenticates but when trying to receive email says "cannot communicate with server". I have deleted the account multiple times and re-added it using both mail.cohenforman.com (port:143 ssl:off) and secure30.webhostinghub.com (port:993 ssl:on).

iOS 7 is the latest version. All my iOS updates have been run

This problem has been occurring intermittently for a few months. It is usually resolved by alternating server and/or deleting the account. Now it cannot be resolved. The problem also occurs for a co-worker suing iOS 7.

Are you sure its not a server side issue or an issue with you implementation of the IMAP protocol?



To ask this user for more information, please first login.

To submit an answer, please login.

ANSWERS

0

arnelc
Staff
13,458 Points
2014-06-03 6:59 pm EST
Hello,

Sorry for the problems you're having with email. I went ahead and created a test account on your server called hubtest@cohenforman.com. Then I proceeded to set this account up on my iPhone 4s. It is running iOS7. Here were my settings - I just used the generic:

Incoming = mail.cohenforman.com
user = hubtest@cohenforman.com
pw= ***

Outgoing = mail.cohenforman.com
user = hubtest@cohenforman.com
pw=***

I then tested both incoming and outgoing emails to and from my gmail account using the iPhone and my Macbook Pro. I had no problems receiving or sending emails.

In reviewing your settings, make sure that you're using port 993 for the outgoing port (it's only for incoming) 143 is also incoming - just not using SSL. The outgoing ports are 587 (non-SSL) and 465 (using SSL).

I hope this clarifies the issue and resolves your problem. I am unable to duplicate the email problem with your account. It does appear to be working with no issue.

If you have any further questionis, please let me know. I plan to do a video tutorial on setting up the iPhone shortly (inspired by your question).

Regards,
Arnel C.

To submit a comment on this answer, please first login.

Firstly, let me say that I do genuinely appreciate your attempt to help. However, what you have done is simply re-iterate and reproduce some of what I wrote in my post. Certainly creating a test account is a good start.

Did you create an IMAP account or a POP account? Is it possible to obtain log entries relating to communication from the IP address of the iphone that can no longer receive mail?

As I indicated in my original post, setup of the account on the phone successfully verifies using the settings I listed, but states "cannot communicate with server" when trying receive. As such, there would at least be server log entries for the authentication events.

I should also point out that none of your support staff have ever asked if POP access works. We would, of course, prefer to use IMAP just as we do for all our personal accounts through other service providers and for the very same reasons your company recommends in its documentation.

Lastly and unrelated to my issue, I'm sure many of your customers would appreciate a video tutorial. You may also want to update the screen shots used on your existing iPhone email setup page as these screen shots are from iOS 1 and are so old many of you customer may be confused as to whether they're in fact reading a current document.

Regards,
Nick
CohenForman
12 Points

2014-06-08 6:35 pm EST
Hello CohenForman,

Sorry to hear you're still having a problem. I tested using an IMAP account (you can always tell IMAP by port numbers: 143 or 993 are the typical industry values).

When I'm creating a "test" account - it's working DIRECTLY in your account. I'm also doing it on an iPhone. We may have a different carrier (I'm using AT&T), but the steps are literally the same.

I tested both sending an email and receiving an email on my own iPhone 4S. Both worked. According to the log files, I'm seeing files being received, email is definitely working (you can see that by using Webmail as opposed to the iPhone). The problem that you're stating is that the phone cannot communicate with the server when receiving emails.

I went back into the log files and there is nothing indicating an authentication issue. This means that the problem doesn't appear to be hitting the server - at least that I can see. Also, email is working normally outside of the iPhone. So operations on the server are normal.

The problem though, is that I can't duplicate that problem on an iPhone here. If it was blocking ALL iPhones, then I wouldn't be able to receive (or send) email from the iPhone test account I created. You have not provided the information you're using for the settings. You say it's confirmed it, but for us to troubleshoot the client (in the case your phone), we would need to know the settings. If you wish to keep the settings private, then create a test account on your end and set it up on your phone. Provide the settings that you're using in reply. When we're done troubleshooting, you can then delete the account.

Apologies again for the headaches. Please send us some further information and we can follow up on the problem

Regards,
Arnel C.
arnelc
13,458 Points
Staff
2014-06-09 2:55 pm EST
Hi,

Thanks for the quick follow up. The settings I’m using are straight from the cPanel X instructions on SSL on non-SSL configuration for IMAP:
Username: ben@cohenforman.com
Password: Use the email account’s password.
Incoming Server: secure30.webhostinghub.com
• IMAP Port: 993
• POP3 Port: 995
Outgoing Server: secure30.webhostinghub.com
• SMTP Port: 465
Authentication is required for IMAP, POP3, and SMTP.

Or

Username: ben@cohenforman.com
Password: Use the email account’s password.
Incoming Server: mail.cohenforman.com
• IMAP Port: 143
• POP3 Port: 110
Outgoing Server: mail.cohenforman.com
• SMTP Port: 587
Authentication is required for IMAP, POP3, and SMTP.

After putting in either set of settings the iphone “veriefies”/confirms authentication and settings. Upon trying to send or receive it immediately states “cannot communicate with server”. This has been occurring on a monthly basis for myself and another employee who also uses an iPhone. Normally the issue is resolved by switching from the settings for mail.cohenforman.com to secure30.webhostinghub.com or vice versa. However, at this point in time neither set of settings will work to receive email though both verify/authenticate. Deleting and recreating the account will not work. Restoring the entire phone to factory defaults and then recreating the account will not work. Both accounts that experience the issue have been in existence for at least 4 years.

You are correct that there is no authentication issue with these devices. Its post authentication that the problem occurs. As such, I’m wondering if this is a case of connection refusal on the server side. Does webhostinghub throttle IMAP requests on a per user or device basis? Certainly that would explain why, previously, switching from one server to another temporarily resolved the issue.

Regards,
Nick
CohenForman
12 Points

2014-06-09 4:20 pm EST
Quick question - when you setup the email on your phone, are you only creating a single email account with IMAP? Or are you using both the POP and the IMAP settings? It's normally one or the other, but you keep listing both, so I wanted to be sure you weren't setting up multiple accounts on your phone. The other reason I ask is that when I check for logins by ben@cohenforman.com, I see a login for POP and IMAP. Please remove the POP account if it's loaded as well. You can receive the email in one or the other protocol - but you shouldn't be using both at the same time.

Also- we are not blocking Apple devices. If we did, this would be a very large issue as we have many people who use our hosting services with their Apple devices.

Regards,
Arnel C.
arnelc
13,458 Points
Staff
2014-06-09 4:43 pm EST
I've had to switch to POP because IMAP no longer works on the phone. There has been no IMAP account on the phone for roughly two weeks. If you see IMAP log entries they're either from my laptop or from the phone dating two weeks ago.

I'm not suggesting you block iPhones at large. When running an IMAP server, you can limit incoming requests to avoid one client from flooding the server. Your companies documentation suggests keeping less than 10,000 messages in your inbox to reduce header requests and thus server load. As previously switching servers resolved the issue, It seems possible your servers were temporarily throttling the devices in question which just happen to be iPhones.

Regards,
Nick
CohenForman
12 Points

2014-06-10 9:22 am EST
Hello Nick,

Thank you for contacting us. Having a large amount of emails (such as 10,000) can definitely cause IMAP issues. For example, every time you sync your IMAP folders (by connecting via IMAP), it has to access and list all 10,000 messages.

That is a lot to access via cell phone network, etc.

We are happy to help by archiving your messages for you, as described in our guide titled Auto archive IMAP mail. The messages are still available via IMAP, but they will be in folders listed by date.

That way when you access your email via IMAP, it will only have to sync current/new messages. This is explained in our article titled Prevent excessive IMAP activity.

With shared hosting, there can be momentary issues, but there are no long IMAP problems on your server.

If our Systems team is forced to suspend you, they will contact/notify you.

You can also use the Resource Usage Tool in cPanel, to see your usage over time.

Also, keep in mind if you are using Wi-Fi to connect to email, different networks have different rules or ports blocked for security. Sometimes, turning the Wi-Fi off and trying to connect to email; or turning the Wi-Fi on and trying to connect to email over the Wi-Fi can help troubleshoot the issue.

If your email problems persist, I recommend contacting Live Support, so they can review the email logs in real-time; while you are attempting to connect.

If you have any further questions, feel free to post them below.
Thank you,

-John-Paul
johnpaulb-whh2
9,258 Points
Staff
2014-06-10 10:17 am EST
We are archiving our mail and have been for weeks prior to this problem. There are no more than 1000 emails in any employees inbox for the entire company. I was referred here by LiveSupport chat.

I'm sorry, but suggesting I did not read the documents regarding inbox management that I literally referred to in my previous post is as unhelpful as telling me to contact the the department that sent me here.

Clearly as the problem is not resolved by the support documentation on your website a solution doesn't exist unless we move our services exclusively to our other host with which we are not having problems.

I guess this is why one of your top 10 questions answered is "how to cancel service with webhostinghub".

CohenForman
12 Points

2014-06-10 3:17 pm EST
Hello Nick,

Sorry that you appear to be still having problems. I spoke at length with John-Paul about this after your last comment. His post includes a lot of general information that can help others with the same type of issue (who may be coming into this problem for the first time). These posts are public, so we typically try to provide general information for anyone encountering the same problem.

The whole "throttling" issue really has more to do with large IMAP mail accounts that are trying to synchronize and affecting server perfomance. This is an IMAP issue that is a common problem faced by any mail admin. However, in your case, as you specified it is not a problem.

His specific recommendations were really leaning more toward the wi-fi settings on your phone to see if it would have an effect with your receiving mail problem. We're basically looking at different factors that could affect the login. Here's a sampling of the Maillog entry for your ben@cohenforman.com email account:

Jun 10 07:02:24 whub30 pop3d: TIMEOUT, user=ben@cohenforman.com, , top=0, retr=0, rcvd=31, sent=55778, time=303
Jun 10 07:12:17 whub30 imapd-ssl: LOGIN, user=ben@cohenforman.com, , protocol=IMAP
Jun 10 07:12:18 whub30 imapd-ssl: LOGIN, user=ben@cohenforman.com, , protocol=IMAP
Jun 10 07:12:19 whub30 imapd-ssl: LOGIN, user=ben@cohenforman.com, , protocol=IMAP
Jun 10 07:12:20 whub30 imapd-ssl: LOGIN, user=ben@cohenforman.com, , protocol=IMAP
Jun 10 07:12:23 whub30 imapd-ssl: LOGIN, user=ben@cohenforman.com, , protocol=IMAP
Jun 10 07:12:33 whub30 imapd-ssl: DISCONNECTED, user=ben@cohenforman.com, headers=0, body=0, rcvd=34, sent=233, time=16, starttls=1
Jun 10 07:23:27 whub30 pop3d: LOGIN, user=ben@cohenforman.com,
Jun 10 07:23:42 whub30 pop3d: LOGOUT, user=ben@cohenforman.com,, top=23079, retr=8224, rcvd=100, sent=112407, time=15
Jun 10 07:23:42 whub30 pop3d: LOGIN, user=ben@cohenforman.com,
Jun 10 07:28:47 whub30 pop3d: TIMEOUT, user=ben@cohenforman.com, top=0, retr=137922, rcvd=139, sent=221185, time=305
Jun 10 07:42:22 whub30 imapd-ssl: TIMEOUT, user=ben@cohenforman.com, , headers=0, body=0, rcvd=85, sent=3423, time=1803, starttls=1
Jun 10 09:23:43 whub30 imapd-ssl: LOGIN, user=ben@cohenforman.com, , protocol=IMAP
Jun 10 09:53:42 whub30 imapd-ssl: TIMEOUT, user=ben@cohenforman.com,, headers=2057, body=31682, rcvd=116220, sent=85996, time=9679, starttls=1
Jun 10 09:59:37 whub30 pop3d: LOGIN, user=ben@cohenforman.com,
Jun 10 10:03:08 whub30 pop3d: LOGOUT, user=ben@cohenforman.com, , top=162579, retr=2132569, rcvd=1158, sent=2414726, time=211


I removed the IP and ports for security reasons. Note that this is only Jun 10. This is several hours worth of logins, and you can see that there are NO indications of problems with the login. I also looked at the exim_mail log and there are no issues there either.

As I have noted earlier, we have many Apple customers on this network and if we were having problems specific to Apple devices then we would easily be able to see a trend with our support issues (and you wouldn't see just your post in regards to the issue).

For a bit I thought that the issue may have had to do with the simultaneous POP and IMAP logins, but I also tested this with my Macbook Pro (running Mavericks) and I still couldn't duplicate the problem. My iPhone mail still received email with no issues and so did my Mac mail client.

The next thing I could do, with your permission, is to test using the Ben@cohenforman.com account. I would have to change the password. I could then see if it's account related. I'm not sure what mail clients you're using off of the iPhone, but you could also try using only iMap for all your devices (or remove the mail accounts or take them offline) so that you can isolate the issue to the iPhone.

Again, I understand that this is a frustrating issue, but we simply want to state the basic facts that we are testing with Apple devices here and we have many customers using Apple devices. If everyone else working, it makes no sense that we would be blocking only your iPhone from receiving email. I am still willing to help figure out the issue if you want to work through it with me.

Regards,
Arnel C.
arnelc
13,458 Points
Staff
2014-06-10 5:08 pm EST
Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.