PHP Version problems with Joomla 3.0 and Moodle 2.4

Asked by:
DACompSC / 5 Points
Time:
2013-07-18 11:58 am EST
Category:
Joomla
Hits:
426
My site is www.dacompsc.com

The last days I was working in deploying and migrate two of our services to new versions. I have more than two weeks working without problem.

Today I try to continue my work and I get errors:

Joomla 3.0 (www.dacompsc.com/j30) sends me: Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!. But we have PHP version 5.3.27.

I don't understand the error mesage that Moodle 2.4 is sending me, but since I was working fine yesterday and today I canĀ“t work in any of this sites I hope that the problem is the same. The site is www.dacompsc.com/CapDis/m24, and the error:


Notice: Use of undefined constant __DIR__ - assumed '__DIR__' in /home/dacomp6/public_html/CapDis/m24/lib/dml/moodle_database.php on line 27

Warning: require_once(__DIR__/database_column_info.php) [function.require-once]: failed to open stream: No such file or directory in /home/dacomp6/public_html/CapDis/m24/lib/dml/moodle_database.php on line 27

Fatal error: require_once() [function.require]: Failed opening required '__DIR__/database_column_info.php' (include_path='/home/dacomp6/public_html/CapDis/m24/lib/zend:/home/dacomp6/public_html/CapDis/m24/lib/pear:.:/usr/lib/php:/usr/local/lib/php:/home/dacomp6/php') in /home/dacomp6/public_html/CapDis/m24/lib/dml/moodle_database.php on line 27

To ask this user for more information, please first login.

To submit an answer, please login.

ANSWERS

0

johnpaulb-whh2
Staff
9,016 Points
2013-07-18 2:40 pm EST
Hello DACompSC,

Thank you for contacting us today. I checked the PHP version available in your cPanel, and it is updated to 5.3.27.

However, the PHP version you are running can be rolled back to older versions, and I noticed yours was set to 5.2.

After setting to 5.3 the errors disappeared, you can always set it back to 5.2 if it is required.

We updated the PHP version on your server last night from 5.3.1 to 5.3.27, which could have affected the version setting in your cPanel.

If you have any further questions, feel free to post them below.
Thank you,

-John-Paul

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.