Moodle Install

Asked by:
PapaJohnSibley / 5 Points
Time:
2012-09-18 10:29 am EST
Category:
Moodle
Hits:
1,554
Moodle 2.1 or later requires at least PHP 5.3.2 (currently using version 5.2.6).
Some servers may have multiple PHP versions installed, are you using the correct executable?

The workaround ( http://www.webhostinghub.com/support/website/moodle/edit-lib-php-file-moodle )
does not work, the following lines of code are not in the lib.php file

public static function get_behaviour_required_behaviours($behaviour) {
$class = 'qbehaviour_' . $behaviour;
return $class::get_required_behaviours();
}

To ask this user for more information, please first login.

To submit an answer, please login.

ANSWERS

0

ScottM
Staff
12,522 Points
2012-09-18 10:58 am EST
Hello PapaJohnSibley,

It does appear that your server has a php version too old for that moodle installation. We can certainly move you to a server that has a newer version. In fact, the newer servers allow you to select your version of php with options of 5.2, 5.3, and 5.4.

To do so, you would need to contact our support department at support@webhostinghub.com with that request. Be sure to validate your account with either the last 4 digits of the credit card on file, or the current Account Management Panel (AMP) password.

Best Regards,
Scott M

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.