Home page loop - page isn't redirecting properly

Asked by:
pixelpadre / 31 Points
Time:
2011-09-04 8:00 pm EST
Category:
Website Troubleshooting
Hits:
3,563
My site madeiniran.com is stuck on a home page loop.

To ask this user for more information, please first login.

To submit an answer, please login.

Best answer chosen by User

0

bradm
Staff
1,846 Points
2011-09-05 7:34 am EST
Hi pixelpadre,

I visited your website and was not able to replicate the issue. Are you still having this problem?

If you have a bad redirect, your homepage can redirect to itself in a endless loop. Most browsers today can sense this and will give you an error message, similar to:

The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

As the problem is most likely in your .htaccess file, to resolve the immediate issue at hand you'll want to disable your .htaccess file. You can do this by renaming it to anything else, such as .htaccess.bak

To disable your .htaccess file:
1. Log into your cPanel
2.
Access your cPanel
3. Find the .htaccess file in your domain's home folder, right click it, and select rename
4. Rename the file as stated above (.htaccess.bak)

I hope this helps! Be sure to let us know if you have any further questions.

Thanks,
- Brad

To submit a comment on this answer, please first login.

ANSWERS

0

bradm
Staff
1,846 Points
2011-09-05 7:34 am EST
Hi pixelpadre,

I visited your website and was not able to replicate the issue. Are you still having this problem?

If you have a bad redirect, your homepage can redirect to itself in a endless loop. Most browsers today can sense this and will give you an error message, similar to:

The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

As the problem is most likely in your .htaccess file, to resolve the immediate issue at hand you'll want to disable your .htaccess file. You can do this by renaming it to anything else, such as .htaccess.bak

To disable your .htaccess file:
1. Log into your cPanel
2.
Access your cPanel
3. Find the .htaccess file in your domain's home folder, right click it, and select rename
4. Rename the file as stated above (.htaccess.bak)

I hope this helps! Be sure to let us know if you have any further questions.

Thanks,
- Brad

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.