500 Internal Server Error on subdomain WP admin panel (many pages)

Asked by:
HubFans / n/a Points
Time:
2015-05-20 6:25 pm EST
Category:
Wordpress
Hits:
1,214
Hi, I recently installed WP 4.2.2 in my subdomain sadedin.evolicious.net and I am having a lot of issues with it.

First, I cannot install new themes. The button in the Themes section of the wp-admin site doesn't trigger anything (no dialog). When I upload a theme manually into the wp-content/themes the Themes page returns a 500 Internal Error. I've tried setting debugging info in my wp-config.php file to no avail.

Second, adding new plugins fails with a 500 Internal Server Error. This is triggered by clicking on "Add new" in the plugins page, or simply navigating to http://sadedin.evolicious.org/wp-admin/plugin-install.php .

Again, I cannot debug this, for the error logs for my site are just about empty, and the raw logs don't seem that informative. An excerpt follows:

216.239.45.84 - - [20/May/2015:18:10:25 -0400] "POST /wp-login.php HTTP/1.1" 302 - "http://sadedin.evolicious.org/wp-login.php?redirect_to=http%3A%2F%2Fsadedin.evolicious.org%2Fwp-admin%2F&reauth=1" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36"
216.239.45.84 - - [20/May/2015:18:10:25 -0400] "GET /wp-admin/ HTTP/1.1" 200 43339 "http://sadedin.evolicious.org/wp-login.php?redirect_to=http%3A%2F%2Fsadedin.evolicious.org%2Fwp-admin%2F&reauth=1" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36"
216.239.45.84 - - [20/May/2015:18:10:26 -0400] "GET /wp-admin/admin-ajax.php?action=dashboard-widgets&widget=dashboard_primary&pagenow=dashboard HTTP/1.1" 500 289 "http://sadedin.evolicious.org/wp-admin/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36"
216.239.45.84 - - [20/May/2015:18:10:29 -0400] "GET /wp-admin/themes.php HTTP/1.1" 500 289 "http://sadedin.evolicious.org/wp-admin/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36"
216.239.45.84 - - [20/May/2015:18:10:32 -0400] "GET /wp-admin/admin-ajax.php?action=dashboard-widgets&widget=dashboard_primary&pagenow=dashboard HTTP/1.1" 500 289 "http://sadedin.evolicious.org/wp-admin/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36"

I have checked the DB (evolic5_wp22) in phpMyAdmin, and everything seems to be in order. I am really hitting a wall here, and don't know how to proceed.

Thanks,

Edgar

To ask this user for more information, please first login.

To submit an answer, please login.

ANSWERS

1

arnelc
Staff
16,171 Points
2015-05-20 6:33 pm EST
Hello Edgar,

Sorry to hear that you're getting 500 server errors when trying to change options within your WordPress installation. The problem has to do with the version of PHP that you're using. By default, the version of PHP is set to 5.2. This will cause problems with WordPress. Fortunately, it's easy to change (and I've already changed it for you). You would need to go into cPanel, click on PHP Configuration, then select the preferred version from the drop-down menu. Save and it's changed! You can also find this information within our tutorial: How to switch your PHP version in cPanel.

The problem should be fixed, but if you have any further questions or comments, please let us know.

Regards,
Arnel C.

To submit a comment on this answer, please first login.

Want to share this Question?

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.