RSS Feed Not Working Properly

Asked by:
HubFans / n/a Points
Time:
2015-12-04 12:05 am EST
Category:
General Information
Hits:
18
My site www.basehitinvesting.com RSS feed is not working properly. Sometimes the feed shows up to date, but often it shows my last post as being September 4th (I've done 4 or 5 since then). My main issue is that Mailchimp (the service that sends my posts via email to my subscribers) is not sending out the posts. Mailchimp says it must be an issue with the RSS feed but other than that they said it isn't a problem on their end. Any suggestions?

To ask this user for more information, please first login.

To submit an answer, please login.

ANSWERS

0

arnelc
Staff
16,171 Points
2015-12-04 9:41 am EST
Hello,

Sorry for the problem with your RSS feed not updating correctly on your website. I double-checked the feed by adding an RSS reader extension to my website and then subscribing to your feed to see it. When I looked at the articles, the latest article I could see was dated September 3. It appears to be related to a possible problem in your WordPress site. I took a quick look and you have errors popping up due to the Jetpack plugin. I would first remove that plugin, then double-check and see if you can get the site to load with no errors. WordPress comes with default RSS feeds, so I'm assuming you're using that function of the site to provide MailChimp content. Otherwise, please identify what feeds you're using to provide MailChimp content so that we can check it. You may also want to try clearing the cache or resetting it. That is another possible culprit to your feeds not updating properly.

I hope this helps to answer your question, please let us know if you require any further assistance.

Regards,
Arnel C.

To submit a comment on this answer, please first login.

Thanks for the quick reply. I deleted my Jet Pack plugin and refreshed the site, emptied the cache, and then checked the feed but it still seems to be only showing the most recent post as Sept 4th. Is there anything else you can recommend?
basehitinvesting
3 Points

2015-12-04 12:59 pm EST
Hello,

According to this WordPress Support forum post, there is the possibility that one of your plugins is causing the issue. Try deactivating them, and then step through each to see if your posts update. You should be able to pinpoint the problem using that method.

If you have any further questions or comments, please let us know.

Regards,
Arnel C.
arnelc
16,171 Points
Staff
2015-12-04 1:21 pm EST
Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.