.htaccess: rewrite rules not working

Asked by:
xchrono / 8 Points
Time:
2012-07-26 9:34 am EST
Category:
General Server Setup
Hits:
813
Hi,

I'm trying to implement navigation by short urls on my site. For a start, make a rewrite rule that points http://www.mydomain.com/info/ to default.htm in the public_html folder.

I'm getting 404 error: "The requested URL /home/.../public_html/default.htm was not found on this server."

My .htaccess file looks like this:

RewriteEngine on
Options +FollowSymLinks
RewriteRule ^info/$ default.htm [L]

What am I doing wrong?

To ask this user for more information, please first login.

To submit an answer, please login.

Best answer chosen by User

0

ScottM
Staff
13,242 Points
2012-07-26 9:48 am EST
Hello xchrono,

The htaccess code in the post here is fine. I tested it what you have on your site and it is working. I also tested further by pointing it to another test file. It also works.

I did need to clear the browser cache between tests to display the most up to date info, so be sure to do that.

If you have any more questions or information specific to the issue please leave a comment below so we can further assist you.

Best Regards,
Scott M

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.