Customers on servers with the default PHP version 5.3 have the option of using either PHP 5.2, PHP 5.3, or PHP 5.4. The default version is 5.3, but can be easily be changed by using the PHP Configuration option in cPanel.

If you are currently on a server that does not support PHP 5.3 and 5.4 but would like to use either PHP 5.3 or 5.4, please submit a request to our Support Department to request an account move. Please make sure you include the cPanel user name or main domain name on the account along with account verification (either your AMP password or last 4 digits of the credit card on file).

Please note, when using the PHP Configuration option in cPanel, this will be an account level change. This will affect all domains and sites on the account.

  1. To switch your PHP version, begin by logging into your cPanel account
  2. Under Software/Services, click the PHP Configuration icon.

  3. php-configuration

  4. On the next page, choose the PHP version you wish to run and click the Update button.

    switch-php-version

  5. The version can be changed between 5.2, 5.3, or 5.4 at any time.

If you have any questions or need any assistance, please feel free to contact us.

Did you find this article helpful?

We value your feedback!

Why was this article not helpful? (Check all that apply)
The article is too difficult or too technical to follow.
There is a step or detail missing from the instructions.
The information is incorrect or out-of-date.
It does not resolve the question/problem I have.
How did you find this article?
Please tell us how we can improve this article:
Email Address
Name

new! - Enter your name and email address above and we will post your feedback in the comments on this page!

Did you find this article helpful?

Comments

2012-02-14 9:41 am
I don't have the PHP configuration icon, only PHP pear packages
Staff
13,688 Points
2012-02-14 10:56 am
Hello genegun,

Thank you for contacting us regarding PHP 5.3. If you are not currently on a server with PHP 5.3, an account move to a server with PHP 5.3 will need to be requested. I have also responded to the email you sent regarding your PHP version. Please respond to that email with the requested account verification (AMP password or last 4 digits of credit card on file) if you would like to move forward with moving your account.

Please let us know if you have any questions or need further assistance.

Regards,

Christi N.
n/a Points
2014-05-24 5:14 pm

I switched my PHP version to 5.2 but still receive the following error when installing Webinsta:  Required PHP version less than 5.3.0 AND found version is : 5.3.28

Staff
1,639 Points
2014-05-27 8:58 am
Sometimes the PHP version switched can fail in writing to your .htaccess file, depending on your particular configuration. To manually change it, place the following within your .htaccess file:

AddHandler application/x-httpd-php52 .php

Post a Comment

Name:
Email Address:
Phone Number:
Comment:
Submit

Please note: Your name and comment will be displayed, but we will not show your email address.

Related Questions

Here are a few questions related to this article that our customers have asked:
Ooops! It looks like there are no questions about this page.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.