Prestashop 1.6 admin white screen, wrong php settings

Asked by:
HubFans / n/a Points
2016-07-08 8:48 am EST
Hi everyone.
I`ve got an own hosting, everything was fine, but now got some trouble without visible reason.
Now, i'm in a dead block. and I want to ask of community help.


The front office working fine, but got a white screen of admin login page.
An error reporting returns nothing, the blank white page only.
A scripting protocol returns:

334","(Warning) Cannot modify header information - headers already sent by (output started at admin_folder/index.php:34)"

But these are warnings only, and back office must work.

I have changed permissions to 0777 for all Prestashop root directory in all of depth, got a similar result.
The cache (/cache/smarty/cache & cache/smarty/compile) cleared manualy.
And location of web server are checked, the info() function returns a correct result from admin directory.
And memory_limit (php.ini) state of 256 Mb.

I have restored all from the working backup for a test, got the similar result.

Obviously, a problem is in a PHP settings or in extensions. But cannot found it myself. Please, HELP!!!

My php.ini
date.timezone = "Etc/GMT"
max_execution_time = 300
memory_limit = 256M
post_max_size = 30M
upload_max_filesize = 16M
max_input_time = 300
max_input_vars = 10000
suhosin.get.max_vars = 10000 = 10000
allow_url_fopen = On
register_globals = Off
safe_mode = Off
safe_mode_gi = Off
allow_url_include = Off
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
expose_php = Off
display_errors = On
log_errors = On
sql.safe_mode = On
Can attach info() page, but how must i do it?

To ask this user for more information, please first login.

To submit an answer, please login.



12,017 Points
2016-07-08 9:12 am EST

Thank you for your question regarding a blank page in PrestaShop. I never recommend using 0777 permissions for files, since they can be accessed and modified by the "world" it can cause security issues/blocks. I recommend resetting your permissions to the standard settings, such as:
public_html - 750
Folders - 755
CGI and Perl scripts - 755
.html .php and other Document Types - 644

As a test try Disabling Mod Security, this will rule out a possible security block.

Have you tried making your php.ini recursive?

What were you working on when this started happening? For example, did you get this issue immediately after installing PrestaShop, after updating, or after installing a new plugin/module?

Just provide a link to any files, screenshots, or information you want to share.

Thank you,

To submit a comment on this answer, please first login.

Hi, John-Paul thanks for answer.
The permissions has been changed for a test.
The mod_security is disabled olrady.
Php.ini works global, for all Prestashop root dirs.

Today, i analized my server`s log files, not found nothing interesting. But was a php updating by security risks:

php55-5.5.36 => pkg-static php55-5.5.37
php55-gd-5.5.36 => pkg-static php55-gd-5.5.37
php55-zip-5.5.31 => pkg-static php55-zip-5.5.37
php55-mbstring-5.5.36 => pkg-static php55-mbstring-5.5.37

I think, it`s not a reason of issue.

Can be some trouble with a URL security token?
The URL of admin page like :
and returns an timeout error, after a long time (about 1 minute). There is not an answer of server. But a shop homepage and all shop works fine.

And info() information can view here
12 Points

2016-07-08 12:39 pm EST
Hello Sam,

Sorry for the problems with the PrestaShop white screen error. John Paul has already touched on the main causes of the issue whenever we've seen it. We've often seen the caching to be a cause for the error. Additionally, sometime's it's also related to issues within the software. You may be aware that you're using the latest version. If you are a Web Hosting Hub customer, we can look to see if there are any errors being generated by the Apache server - that would help as well. Make sure you are in debug mode. You might want to go directly into the PrestaShop support forums. They often have many really good posts by experienced PrestaShop users that may help.

Apologies again for the issues. I hope they are resolved soon!

If you have any further questions or comments, please let us know.

Arnel C.

16,349 Points
2016-07-08 1:24 pm EST
Unfortunately, i can not update or install a last version of Prestashop. Got a simular error at the entrance to install catalog.
12 Points

2016-07-08 1:38 pm EST
Hi guys.
Have some ideas?
Got a one elaboration. This issue has a one strange circumstance.
When i disabled allow_url_fopen php.ini option, can load my admin pannel. But this option must be "On" in accordance with prestashop system requirements. What is the conflict?
12 Points

2016-07-13 2:02 am EST
Hello Sam,

Sorry for the continued problems. When I look up the issue, I'm seeing this response in the Prestashop forums . My suggestion is that you post in the forum to pursue the issue further. The PrestaShop community may have experienced something similar.

If you have any further questions or comments, please let us know.

Arnel C.
16,349 Points
2016-07-13 2:14 pm EST
It solved
The automatic cache purification shell script sets a wrong permissions of cache dirs.
It was fogotten.
12 Points

2016-07-22 3:56 am EST
Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.