Can I install osCommerce 3.0.2?

Asked by:
awesomeWebSight / 8 Points
2011-11-02 1:40 am EST
According to the osCommerce site, I have to start over in order to use the newer one because it will not update internally. It just says I have the latest version but there is 3.02 which is suppose to be more secure. Any thoughts or ideas?

To ask this user for more information, please first login.

To submit an answer, please login.

Best answer chosen by User


13,688 Points
2011-11-02 8:50 am EST
Hello awesomeWebSight,

Thank you for your question regarding Fantastico and osCommerce versions. Version 2.3.1 of osCommerce is the version installed by the latest release of Fantastico de Luxe. This is likely due to the PHP requirements of osCommerce 3.0.2 which requires PHP 5.3 or above. Version 5.3 of PHP has some compatibility issues with software built with PHP 5.2 or older, so we wouldn't be able to upgrade the server to PHP 5.3 as it could cause issues for other users on the server who may be running software that wouldn't be compatible. We do apologize for any inconvenience.

We can certainly understand your concerns about security for your site. I would recommend checking out the osCommerce forums, specifically their area devoted to discussions about security:

osCommerce Forums: Security

I hope this helps to clarify this for you. Please let us know if you have any additional questions or need further assistance.


Christi N.

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.