I added a domain which uses modx and it does not work as expected

Asked by:
HubFans / n/a Points
Time:
2015-12-17 1:08 pm EST
Category:
Website Troubleshooting
Hits:
68
I have a main domain.
I added another domain to host here.
Both domains use modx.
When I access the second domain by <main-domain-url>/<new-domain-url>, it seems to work.
When I access the second domain by <new-domain-url>, it only partially works. Some resources seem not to load.
What might I have done wrongly?

To ask this user for more information, please first login.

To submit an answer, please login.

ANSWERS

0

johnpaulb-whh2
Staff
12,339 Points
2015-12-17 2:07 pm EST
Hello,

Thank you for your contacting us about an issue with Modx displaying correctly. I looked at the source of the site in question, and it is calling in files from a folder. Such as example.com/example.com

Since the Addon domain is already set to resolve to this document root, there is no need to look inside the /example.com folder.

I have seen some cases where clearing the cache in Modx corrects the folder paths.

If that doesn't work, you may have to ensure your "$base_url" to '/' as described in this forum post.

If you have any further questions, feel free to post them below.

Thank you,
John-Paul

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.