wordpress amazon plugin not working

Asked by:
marlandc / 5 Points
2012-04-25 11:02 pm EST
In order for this plugin to work, I'm being told to change the value of "allow_url_fopen" to "1" - here is the info from the plugin FAQ:

Q: I tried to install the Amazon Product Widget-Plugin and am getting the following error while trying to save configuration: file_get_contents() failed. Please ensure that PHP's native function file_get_contents() is allowed to read URL's Configuration could not be saved!

A: The Amazon Product Widget make use of the PHP function "file_get_contents()" to read data from the Amazon API. But sometimes the default PHP configuration (php.ini) does not allow to read URLs due to security reasons. Change the value of "allow_url_fopen" to "1". More information about this issue: http://www.php.net/manual/en/filesystem.configuration.php#ini.allow-url-fopen

To ask this user for more information, please first login.

To submit an answer, please login.



13,688 Points
2012-04-26 8:25 am EST
Hi marlandc,

I'm sorry you're having trouble setting up your WordPress plugin. Your php.ini file is located in your public_html folder. You can edit this file using the cPanel File Manager and to change the "allow_url_fopen" line. For more information, please see our tutorial on How do I Update my Local PHP Settings.

Please let us know if you have any additional questions or need further assistance.


Christi N.

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.