Stats and Temporary URL for Addon Domain

Asked by:
jbrown / 8 Points
2012-03-28 6:28 am EST
I have created an addon domain. I put it in home/ rather than home/public_html/ because I read that this would create a more separate domain and allow me to view separate webalizer stats. However, I don't see the addon domain as an option when I open webalizer. Am I missing a step that would enable stats for the addon domain seperate from the main domain?

Also, I was under the impression that I could test my addon domain by using my temp url/ But when I go that address, I get a hub screen that just displays the server name and ip address.

The addon domain is a static html site (not wordpress or domain specific.) Is there another way I can check the site before I point the domain name? Is the fact that I put it in home/ rather than home/public_html/ the issue?

If anyone can help me out with some insight, I'd be much obliged.

To ask this user for more information, please first login.

To submit an answer, please login.

Best answer chosen by Web Hosting Hub staff


13,688 Points
2012-03-28 3:36 pm EST
Hello jbrown,

I'm sorry you're having trouble with your Addon domain. Yes, the issue you are experiencing is due to the Addon domain being created above the public_html directory. It's not necessary to create it above public_html in order to view stats in Webalizer. When you go to the Webalizer area in cPanel you will have the option to select which domain you want to see stats for.

Creating the Addon domain above public_html is also affecting the use of the temporary URL for testing. Since the part of temporary URL before goes to public_html directory, there's no way to view the Addon domain folder when it's above public_html. Once you have removed and recreated the Addon domain under public_html you shouldn't have any trouble using the Addon domain's temporary URL to view your site before pointing the domain to our Nameservers.

Please let us know if you have any additional questions or need further assistance.


Christi N.

To submit a comment on this answer, please first login.



2017-01-18 5:03 pm EST
I had the exact same problem. What you need to do is edit your computer's hosts file - there may be other ways but this was the simplest solution for me. I wrote the steps in detail here, hope this helps:

To submit a comment on this answer, please first login.

Want to share this Question?

Related Articles

It looks like there are no related articles.
Would you like to ask a question about this page? If so, click the button below!

Help Center Search

Current Customers

Email: Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.