Want to get rid of old domain and use a new, pointed domain on my site

Asked by:
sholly / 8 Points
Time:
2015-01-05 11:44 am EST
Category:
Domain Pointing
Hits:
567
Hi, I recently registered a domain with you, let's call it abc.com and have created a wordpress website under this domain.

I have since decided I don't like the domain name and have since purchased two others: xyz.com and xyz.co.uk from 1and1 internet.

Today I pointed these two domains at the webhosting hub nameservers.

My questions are:

1. What do I need to do to make the xyz.com address the main address for my wordpress website?

2. How can I completely disconnect the abc.com url from my website? (I no longer want to use this URL at all)

3. How can I point the xyz.co.uk url at my site without it being the primary url for my site.

Sorry, I did read the documentation but I'm a newbie to websites etc and found it a bit confusing.

THANK YOU!

To ask this user for more information, please first login.

To submit an answer, please login.

Thanks Scott M.

So far I've changed the primary domain name. At the moment when I click on the new url which is associated with my wordpress installation it just takes me to a white page with the old url, servername and ip address. I can't get to my Wordpress dashboard at the moment. Does this mean the new url pointing hasn't yet propagated over to webhostinghub? Should I just wait a few hours and try again, or has something gone wrong? :(

Thanks.
Sholly
sholly
8 Points
2015-01-05 12:46 pm EST
Hi again Scott and Arnel.

The new url has now had longer than 24 hours to get to your nameservers. I've updated my primary url to xyz.com and changed the wordpress installation so the wp web address is now xyz.com and the admin is xyz.com/wp-admin (the database names etc are unchanged). I've also cleared the cache in the browser history.

however, when I click on the wp-admin icon i still get a white page with your logo on it and the server name and IP address. The url in the top of the page is abc.com which is the old url that I don't want to use anymore.

Can you help please? When I've done a similar thing before, using domains bought from 1and1 and pointed them to the IP address of a hosting company I've never had any problems. Not sure what is going on here.

Thanks
Shola
sholly
8 Points
2015-01-06 12:03 pm EST
Hi,

I have removed the redirect as I think it was confusing the issue. Let's forget about it for now.

I still have a problem. I don't want my new domain xyz.com to be an addon. I want it to be my primary domain and to have only a single wordpress installation which users can reach by typing xyz.com. I don't want them to see abc.com (the original web address) when they get there. I don't plan to use the abc.com address at all.

Any suggestions as to why, even though I've added xyz.com to the wordpress install and have added it as my primary domain, it doesn't work?

Thanks
sholly
8 Points
2015-01-06 12:54 pm EST
OK, thanks Jeff. Sorry, I'm a novice in these matters.

So I guess I should revert to the old primary domain and back up my data before the new installation?

So the steps are:

install a new version of wordpress for the new primary domain?

And how will I tell wordpress where all my current database files are once I do the install with the new domain?

Cheers.
sholly
8 Points
2015-01-06 01:13 pm EST
OK thanks, whereabouts exactly in the config file do I add this info? I spoke with tech support today and they mentioned having to rebuild the config file for CPanel. When I looked at the file it contained this line:

define('DOMAIN_CURRENT_SITE', 'abc.com');

where 'abc.com' is the original url I want to get rid of and replace with xyz.com

If I put xyz.com in the same place will it fix the problem? if not then do I just paste

define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');

anywhere in the file?

*************

Tech support had said they'd made changes to the file and they would take 4+ hours to propagate but I'm not seeing how the file is any different. I'm not a coder of course.

Thanks for your advice.

Shollly
sholly
8 Points
2015-01-06 05:13 pm EST
OK, I did as suggested and change the site to blockbusterbride.com but when I went to click on wp-admin to edit the site I got this message:
Error establishing database connection
Could not find site blockbusterbride.com. Searched for table sbw1blogs in database songbe5_sbw1. Is that right?

Any ideas?
sholly
8 Points
2015-01-06 06:24 pm EST
What do I adjust them to? I just checked and the database names are the same in the config file as the names in the wp installation admin page that I reach directly from cpanel - wordpress.

If I call your help desk is there someone who can walk me through this on the phone until it's resolved? I thought it would be a straightforward change to point the domain to WHH name servers. Thanks.
sholly
8 Points
2015-01-06 06:40 pm EST

ANSWERS

0

ScottM
Staff
16,266 Points
2015-01-05 12:01 pm EST
Hello Sholly,

Thank you for your questions today. I will answer them in the order they were asked:

1. What do I need to do to make the xyz.com address the main address for my wordpress website?
You will first want to change your primary domain name so that xyz.com is the main domain for your account. Then you can simply change the URL for WordPress to match the new domain name.

2. How can I completely disconnect the abc.com url from my website? (I no longer want to use this URL at all)
Once you replace the primary domain name, the original name will no longer be associated with the account unless you set it as a parked or addon domain.

3. How can I point the xyz.co.uk url at my site without it being the primary url for my site.
You can add the xyz.co.uk as a domain redirect, so that when a visitor types it in, it redirects to the xyz.com site for you.
Kindest Regards,
Scott M

To submit a comment on this answer, please first login.

Thanks Scott M.

So far I've changed the primary domain name. At the moment when I click on the new url which is associated with my wordpress installation it just takes me to a white page with the old url, servername and ip address. I can't get to my Wordpress dashboard at the moment. Does this mean the new url pointing hasn't yet propagated over to webhostinghub? Should I just wait a few hours and try again, or has something gone wrong? :(

Thanks.
Sholly
sholly
8 Points

2015-01-05 12:45 pm EST
Hello Sholly,

Sorry for the confusion. When you make a change like you have, it usually a period of propagation (up to 24 hours) before a change like that completes. The internet refers to everything through addresses and when an address change of this nature occurs, it needs a little time to update. You may also want to make sure to clear your browser cache to make sure that you're not looking at older cached pages on your internet browser.

I hope this helps to answer your question, please let us know if you require any further assistance.

Regards,
Arnel C.
arnelc
16,171 Points
Staff
2015-01-05 12:54 pm EST
Hello sholly,

Currently, I see that you have your primary domain redirecting to another domin, but that other domain is not appropriately added as an addon domain or parked domain. Adding this second domain as an addon domain, then installing WordPress on the addon domain should resolve the issue.
JeffMa
2,342 Points
Staff
2015-01-06 12:22 pm EST
If you installed WordPress prior to changing your primary domain, WordPress itself is causing the redirect as it was configured for a different domain. With a fresh installation, it is easiest to simply uninstall WordPress and reinstall it using the new primary domain.
JeffMa
2,342 Points
Staff
2015-01-06 1:03 pm EST
There's no need to change your primary domain back. If you have already made changes to that WordPress installation, configure WordPress to use that new domain. To do so, simply add these lines to your wp-config.php file, adjusting for your new domain:

define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');

JeffMa
2,342 Points
Staff
2015-01-06 1:18 pm EST
Are you running WordPress Multisite? In that case, simply change the DOMAIN_CURRENT_SITE definition to your new domain.
JeffMa
2,342 Points
Staff
2015-01-06 5:40 pm EST
It sounds like your database connection settings may be incorrect. To correct them, adjust your database name, user, and password within your wp-config.php file.
JeffMa
2,342 Points
Staff
2015-01-06 6:30 pm EST
The name of the database, user, and password will all vary depending on what you initially set them to when creating it. Your database name and user can be found by logging into cPanel and clicking on MySQL Databases.

Live support will indeed be happy to work with you in resolving the issue if you would prefer a live conversation.
JeffMa
2,342 Points
Staff
2015-01-06 6:57 pm EST
Want to share this Question?

Help Center Search

Current Customers

Email: support@WebHostingHub.com Ticket: Submit a Support Ticket
Call: 877-595-4HUB (4482)
757-416-6627 (Intl.)
Chat: Click To Chat Now

Ask the Community

Get help with your questions from our community of like-minded hosting users and Web Hosting Hub Staff.

Not a Customer?

Get web hosting from a company that is here to help.